[Resolved] Can't connect controller over bluetooth  

   RSS

1

Before I used InputMapper 1.7, I had previously installed IM 1.6 and DS4Windows, but neither of them worked, so I thought I'd make the switch to this instead since it's a little more recent. Still having no luck, though.

Just to make sure, once the driver for DS4Windows is removed using ScpDriver.exe and the program files are deleted, there shouldn't be any interference from it, right? After that was done, I uninstalled the bluetooth and Xbox 360 drivers on Device Manager before reinstalling 1.6 and again before installing 1.7.

 

My OS is Windows 10 Pro, version 1809, and I'm connecting to bluetooth through my motherboard. I'll link to the model's webpage in case it helps. removed link

 

I am able to connect the controller to IM when it's plugged in at least, and there doesn't seem to be any issues with Windows picking it up, either. Under Bluetooth & other devices in Windows settings, "Wireless Controller" is listed as "connected," but the controller shows a light blue color and it still doesn't show in IM.

I've attached a screenshot of an error message that came up after a few minutes (give or take) of trying to connect the controller wirelessly.

This topic was modified 1 month ago by Lazzil

@lazzil

Your probably not going to have much luck getting the DS4 to work with a motherboard Bluetooth chipset. DS4 controllers work best using a USB dongle with a broadcom chipset, any other chipset may lead to the same problems.

Pardon the delayed reply; I kinda put off buying the dongle for a short while, but I got it now. Looks like that actually resolved the issues. The controller connected and is staying connected after I used the dongle, and nothing seems to be bugging out atm. I never would've thought a motherboard chipset would be less reliable for controllers than Bluetooth dongles, but I guess that's the way it is. At least the dongles aren't that pricey.

Thank you! 🙂

Share:

Designed by DSD Consulting Services

Please Login or Register